“”

LESS compiler for TYPO3

ws_less / stable

Compiles LESS files to CSS files.

This version supports TYPO3

Older versions also support TYPO3

Composer support

composer req svewap/ws_less

Tags

#less #bootstrap #compiler #phpless

Last upload comment

Fixed version compatibility. TYPO3 8.7 is not allowed since version 1.5.0

Downloads by month

Download 1.5.2 Extension Manual Code Insights Packagist.org
Author
Sven Wappler
Company
WapplerSystems
Last update
03. Jul 2020
First upload
27. Dec 2012
Downloads
13,353
Category
Frontend
Dependencies
  • TYPO3 (9.5.0 - 10.4.99)
  • PHP (7.2.0 - 7.4.99)

Installation

  1. Download ZIP file
  2. Log into your TYPO3 backend
  3. Go to Extension Manager module
  4. Press the upload button on the top bar
  5. Select the ZIP file and upload it. If you want to overwrite an existing extension installation, activate the checkbox.
  1. Go to your folder where the root composer.json file is located
  2. Type: composer req svewap/ws_less to get the latest version that runs on your TYPO3 version.
  1. Download T3X file
  2. Log into your TYPO3 backend
  3. Go to Extension Manager module
  4. Press the upload button on the top bar
  5. Select the T3X file and upload it. If you want to overwrite an existing extension installation, activate the checkbox.

Other extensions by this user (7)

Version history

Version Upload comment Works with TYPO3 Download
1.5.2 / stable
July 03, 2020
Fixed version compatibility. TYPO3 8.7 is not allowed since version 1.5.0
9.5.0 - 10.4.99 Download
1.5.1 / stable
July 01, 2020
changed less compiler to wikimedia distribution. Thanks to Oliver Schlöbe for maintaining the code.
8.7.0 - 10.4.99 Download
1.5.0 / stable
July 01, 2020
TYPO3 10 compatibility
9.5.0 - 10.4.99 Download
1.4.5 / stable
June 17, 2020
TYPO3 9 compatibility; added missing less lib
8.7.0 - 9.5.99 Download
1.4.4 / stable
June 17, 2020
T3 9 compatibility
8.7.0 - 9.5.99 Download
1.4.3 / stable
November 17, 2016
Fixes an error that causes a lot of compressed files to be created, if you use less variables by typoscript
6.1.0 - 7.6.99 Download
1.4.2 / stable
July 31, 2016
Some improvements. Faster, and now officially compatible to 7.6
6.1.0 - 7.6.99 Download
1.4.1 / stable
June 23, 2016
Compatible to version 7.6
6.2.0 - 7.9.99 Download
1.4.0 / stable
April 07, 2015
Now uses namespaces. Documentation updated. Variables are hashed too.
6.1.0 - 6.2.99 Download
1.3.4 / stable
June 02, 2014
Update of the less.php compiler
6.0.0 - 6.2.99 Download
1.3.3 / stable
February 07, 2014
Changed parser which is compatibel with bootstrap 3
6.0.0 - 6.2.99 Download
1.3.2 / stable
October 22, 2013
Bugfix for: Output dir not working when typo constants used
6.0.0 - 6.1.99 Download
1.3.1 / stable
September 26, 2013
Bugfix: Now compiles multiple files again like used in Bootstrap 2
6.0.0 - 6.1.99 Download
1.3.0 / stable
September 18, 2013
Now you can use variables before compiling the less files
6.0.0 - 6.1.99 Download
1.2.2 / stable
August 20, 2013
Update to lessphp version 0.4.0
>= 4.6.0 Download
1.2.1 / stable
May 24, 2013
various improvements
>= 4.6.0 Download
1.2.0 / stable
March 20, 2013
Now with cache functionality and better doc. Thanks to Jozef Spisiak from Pixelant.se
>= 4.6.0 Download
1.1.1 / stable
February 26, 2013
Now compatible with 4.6 and newer
>= 4.6.0 Download
1.1.0 / stable
January 14, 2013
Requires now TYPO3 v6.0
>= 6.0.0 Download
1.0.1 / beta
December 27, 2012
First upload
Download