“”

Amazon AWS S3 FAL driver (CDN) Amazon AWS S3 FAL driver (CDN)

aus_driver_amazon_s3 / stable

Provides a FAL driver for the Amazon Web Service S3.

This version supports TYPO3

Older versions also support TYPO3

Composer support

composer req andersundsehr/aus-driver-amazon-s3

Tags

#fal #driver #amazon #s3 #cdn #aws #cloud #typo3 #backend #Frontend

Last upload comment

Security update.
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3

Downloads by month

Download 1.12.1 External Manual Found an Issue? Code Insights Packagist.org Donate and Give Kudos
Author
Markus Hölzle
Company
different.technology
Last update
18. Oct 2022
First upload
11. Aug 2014
Downloads
113,689
Category
Backend
Dependencies
  • TYPO3 (10.4.0 - 11.5.99)

Installation

  1. Download ZIP file
  2. Log into your TYPO3 backend
  3. Go to Extension Manager module
  4. Press the upload button on the top bar
  5. Select the ZIP file and upload it. If you want to overwrite an existing extension installation, activate the checkbox.
  1. Go to your folder where the root composer.json file is located
  2. Type: composer req andersundsehr/aus-driver-amazon-s3 to get the latest version that runs on your TYPO3 version.
  1. Download T3X file
  2. Log into your TYPO3 backend
  3. Go to Extension Manager module
  4. Press the upload button on the top bar
  5. Select the T3X file and upload it. If you want to overwrite an existing extension installation, activate the checkbox.

Other extensions by this user (3)

Provides a multi-factor authentication via SMS for TYPO3 (requires external SMS provider)

Supported TYPO3 versions:

Send emails with AWS SES.

Supported TYPO3 versions:

Migrate your TYPO3 content from fluidcontent to flux

Supported TYPO3 versions:

Version history

Version Upload comment Works with TYPO3 Download
1.12.1 / stable
October 18, 2022
Security update.
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
10.4.0 - 11.5.99 Download
1.12.0 / stable
April 02, 2022
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
10.4.0 - 11.5.99 Download
1.11.1 / stable
March 04, 2021
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
9.5.0 - 10.4.99 Download
1.11.0 / stable
March 03, 2021
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
9.5.0 - 10.4.99 Download
1.10.0 / stable
May 26, 2020
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
9.5.0 - 10.4.99 Download
1.9.0 / stable
July 12, 2019
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
8.7.0 - 9.5.99 Download
1.8.0 / stable
February 01, 2019
Legacy TER release, please install via Composer
https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
8.7.0 - 9.5.99 Download
1.7.1 / stable
May 13, 2018
Security update, please update
7.6.0 - 9.5.99 Download
1.7.0 / stable
February 16, 2018
Legacy TER release, please install via Packagist / Composer https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
7.6.0 - 9.5.99 not available
due to vulnerabilities
1.6.0 / stable
November 22, 2017
Legacy TER release, please install via Packagist / Composer https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
7.6.0 - 8.7.99 not available
due to vulnerabilities
1.5.5 / stable
August 08, 2017
Legacy TER release, please install via Packagist / Composer https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
6.2.0 - 8.99.99 not available
due to vulnerabilities
1.5.4 / stable
July 10, 2017
Legacy TER release, please install via Packagist / Composer https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
6.2.0 - 8.99.99 not available
due to vulnerabilities
1.5.3 / stable
March 22, 2017
Legacy TER release, please install via Packagist / Composer https://packagist.org/packages/andersundsehr/aus-driver-amazon-s3
6.2.0 - 8.99.99 not available
due to vulnerabilities
1.5.0 / stable
October 08, 2016
TYPO3 8.x release, bugfixes, added connection test
6.2.0 - 8.99.99 not available
due to vulnerabilities
1.4.0 / stable
May 31, 2016
Update AWS PHP SDK to version 3.18 and some bugfixes
6.2.0 - 7.99.99 not available
due to vulnerabilities
1.3.2 / stable
November 16, 2015
Release for TYPO3 CMS 7.6 LTS
6.2.0 - 7.99.99 not available
due to vulnerabilities
1.3.1 / stable
September 02, 2015
Bugfix for TYPO3 6.2.14
6.2.0 - 7.99.99 not available
due to vulnerabilities
1.3.0 / stable
May 02, 2015
Bugfixes and TYPO3 7.2 compatibility, thanks to Morton Jonuschat
6.2.0 - 7.99.99 not available
due to vulnerabilities
1.2.0 / stable
March 28, 2015
Some bugfixes and new features: support cache headers for files
6.2.0 - 7.99.99 not available
due to vulnerabilities
1.1.0 / stable
December 05, 2014
Release for TYPO3 CMS 7.0, new AWS SDK
6.2.0 - 7.0.99 not available
due to vulnerabilities
1.0.8 / stable
November 18, 2014
New feature: index image metadata
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.7 / stable
September 26, 2014
Important bugfix
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.6 / stable
September 24, 2014
Updated documentation
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.5 / stable
September 23, 2014
Changed settings, added hook, updated documentation
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.4 / stable
September 09, 2014
Bugfix in date time format
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.3 / stable
August 27, 2014
Bugfix when creating folders
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.2 / stable
August 25, 2014
Supports DNS prefetching, added Russian support
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.1 / stable
August 14, 2014
Updated documentation
6.2.0 - 6.2.99 not available
due to vulnerabilities
1.0.0 / stable
August 11, 2014
Release 1.0.0
Requires TYPO3 CMS 6.2
6.2.0 - 6.2.99 not available
due to vulnerabilities